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Chapter 

15
DigiLinX Streaming Music Manager

The Streaming Music Manager (SMM100) is a hardware device designed to mine a 
computer network for MP3 and WAV music files and playlists (M3U). It builds a 
database and makes them available to the DigiLinX network. DigiLinX can then 
browse the database, locate files, and display metadata from those files. 

Installation of the SMM100 requires four steps:
1. Use the DigiLinX Dealer Setup program to configure the DigiLinX system to 

recognize the SMM100.
2. Configure the PC. 
3. Set security (if applicable).
4. Add cover art.

CAUTION! To power down the SMM100, press the button on the front of the unit. Do 
not unplug the power cord.

Following installation is a discussion of examples of software for ripping music.

You can have a DigiLinX only network or you can combine your home computer 
network with DigiLinX so that the SMM100 can access the music source (computer, 
USB storage device, or NAS drive).

NOTE: The IP address of DigiLinX network and the home network must match for the 
SMM100 to find network shared music on the home network. Also, the 
gateway, DNS, and subnet mask must match. The PC must be part of the 
NetStreams workgroup in order to share the music. The PC cannot be a domain 
computer.

If you want to connect DigiLinX to your existing home network, see Figure 15-1.
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Figure 15-1 DigiLinX and a Home Network

NOTE: This is the recommended method of integrating an SMM100 with a home 
network.

Step 1: Configure the SMM100 with DigiLinX Dealer Setup
The SMM100 ships with an IP address of 10.15.1.25. This address can be changed 
from DigiLinX Dealer Setup by selecting Show Advanced Options on the Info tab. 

The steps to configure an SMM100 in DigiLinX Dealer Setup are similar to those of 
other media servers. Please follow procedures in this section to configure the SMM100 
for use with a DigiLinX network. You must update the devices in Dealer Setup before 
proceeding. 

All IP addresses for the home network, static devices, and DigiLinX devices must have 
the same IP addressing scheme and the same subnet mask for the devices to 
communicate. NetStreams recommends a Class C subnet mask of 255.255.255.0. Most 
home routers use a Class C address.

Adding an SMM100 to a Project
To add an SMM100 to a project, complete the following steps:
1. Open DigiLinX Dealer Setup.
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The SMM100 should appear in the list of devices as your hardware is auto-
discovered.

2. Select File>Open. Select a file from the list or create a new one by using 
File>New.

3. Select the Add Device ( ) icon.
The Add Devices area displays (see Figure 15-2).

Figure 15-2 Add Devices area

4. Enter a 1 next to Media Server and select Add to Project.
You are prompted for information about the media server (see Figure 15-3).

Figure 15-3 Media Server information
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5. Enter the following:
a unique server name in the Media Server Name field
select Streaming Music Manager from the dropdown list in the Server Type 
field
a network IP address that is valid for the DigiLinX and home network.

6. Select Save & Continue.
A media server displays in the device list in the left window pane (see  
Figure 15-4).

Figure 15-4 Media Server added

7. Highlight the Streaming Music Manager in the left window pane and select the 

Match Devices ( ) icon.
You are prompted to select the device you want to match from a list (see Figure 15-
5).
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Figure 15-5 Selecting a device from the list

8. Highlight the SMM100 in this list and select OK.
A message displays asking if you want to change the IP address in the project to 
reflect the IP address of the actual media server (see Figure 15-6).

Figure 15-6 IP address prompt

NOTE: If the IP address entered into the project for the SMM100 does not match the IP 
address that the SMM100 is currently using, DigiLinX Dealer Setup will 
display a warning message. Selecting NO will change the IP address currently 
being used by the SMM100 to the address entered in the project. Selecting YES 
will change the IP address in the project so it matches the IP address currently 
being used by the SMM100.

The device appears in the device list with a yellow exclamation mark next to it that 
indicates the SMM100 has been properly matched, but needs configuration.

Editing Information
To edit information for the SMM100, highlight the SMM100 in the device list so that 
the Info tab displays (see Figure 15-7).
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Figure 15-7 Info tab

9. Select the Settings tab.
Settings information displays (see Figure 15-8).

Table 15-1
SMM100 Info Tab

Tab Selection Description
Info Current IP Address The IP address currently used by the SMM100.

Subnet Mask The subnet mask of the SMM100.
Device Type Should always be SMM for an SMM100.
Model Number The model number of the SMM100.
Firmware Version The version of the SMM100 firmware.
Device Name: The name you gave the device when you added it to the 

project.
Override Changes the default device name. Keep unchecked in most 

instances.
Serial Number The serial number of the device attached to the DigiLinX 

network.
Device Comments Indicate where the device is installed so that if you need to 

return to the installation for service or upgrading devices, you 
can have access to this information in the project file.

Device Summary Name The name you gave the device when you added it to the 
project.

CoverArt File names the SMM100 uses for cover art you have added.
Folder Names Keywords for folder names that indicate where to look for 

media.
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Figure 15-8 Settings information tab

10. Edit the following (as needed):
Name - enter the name of the SMM100
Cover Art - edit cover art by:

adding - select Add to add keywords for folder names that indicate where 
to look for media

removing - highlight the cover art keyword you want to remove and select 
Remove

editing - select an item to edit it.
Folder names - edit folder names by:

adding - select Add to add keywords for the SMM100 to use in searching 
for music folders

removing - highlight the folder name keyword you want to remove and 
select Remove

editing - select an item to edit it.
Select Apply.

11. Select the Streams tab.
Stream information displays (see Figure 15-9). This process is the same as it is for 
setting up any media server.
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Figure 15-9 Digital Media Server Streams tab

The Streams tab allows you to name the streams of audio coming from the 
SMM100 and assigns a SpeakerLinX or MediaLinX to manage (proxy) those 
streams. 

NOTE: The maximum number of streams for an SMM100 is six.

Assigning Streams
Assign streams by checking the enabled box next to the stream name.

NOTE: Streams of audio display in the sources menu of the TouchLinX screen as 
separate sources. 

Editing Streams
To modify streams:

You can enable a stream by selecting the check box under Enabled. If you do not 
want to enable the stream, uncheck the check box under Enabled and select Not 
Assigned under the Proxy Device.

Click on the stream name to make the field editable and change the name as 
desired.

Change the proxy device by selecting the source for the stream from the dropdown 
list.

www.netstreams.com


DigiLinX Streaming Music Manager

15-9
All specifications subject to change without notification.  All rights reserved.  Copyright © 2008 NetStreams

Main +1 512.977-9393 / fax +1 512.977.9398 / Toll Free Technical Support +1 866-353-3496
3600 W. Parmer Lane, Suite 100; Austin, TX 78727 / www.netstreams.com.

Enter the number of streams you want to enable for the device.

Auto Assign assigns an IP address based on the Auto IP range discussed in the IP 
and DigiLinX Tutorial on page 2-13.

Sending the Configuration
1. With the project open to the changes you just made, select the Send Configuration 

to Multiple Devices icon.
2. Select File>Save to save the project.
3. Wait for the devices to restart. The Streaming Music Manager is ready when 3 

green check marks appear in the upper right corner of the display (if you have 
attached a display).

Step 2: Configure the PC
For the Streaming Music Manager to locate and catalog music on a PC or NAS 
(Network Attached Storage) drive, there are certain settings that need to be made.

Enable the guest account.

Set the workgroup to Netstreams.

Note the Gateway and DNS of the PC and enter them into the Streaming Music 
Manager.

Verify that there are no PC firewalls or security programs blocking access to the 
shared folders.

Make the folder containing the music a shared folder.

Restart the PC and the Streaming Music Manager.

Enable the Guest Account
By default, the Streaming Music Manager will use the guest account to connect to the 
network shzre. The guest account is disabled by default. If the guest account cannot be 
used, you can setup a custom security ID. For setting up security, see Setting Security 

Table 15-2
Digital Media Server Streams Tab

Tab Selection Description
Streams Enabled Indicates if the stream is active or has been turned off.

Streams The name given to the stream which is displayed on the GUI.
Proxy Device Denotes what device is hosting or proxying the stream.
Maximum Number of Streams When Auto Assigning the stream, this setting lets you 

configure how many streams you want enabled.
Auto Assign Automatically assigns the maximum number of stream to an 

available DigiLinX device.
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Set the Workgroup to NetStreams
The Streaming Music Manager is pre-configured to use the work group Netstreams. 
The PC that contains the music will also need to use the workgroup Netstreams. 

Set the  DNS and Gateway
The Streaming Music Manager needs to be configured with the home network’s DNS 
and Gateway. The easiest way to determine the home network’s DNS and gateway 
address is to look it up on the PC with music. To do this, follow these instructions.
1. Go  to the PC.
2. Click on Start.
3. Select Run.
4. Type: 

CMD/
5. Click OK.
6. Enter: 

 IPCONFIG /ALL
7. Several lines of TCP/IP information will appear. Look for the term ‘Default 

Gateway’ and note the IP address next to it as shown in Figure 15-10.

Figure 15-10 TCP/IP Infomation
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8. Next, look for the IP address of the DNS server and note its first address.
9. Then, go to DigiLinX Dealer Setup. Select Streaming Music Manager. On the Info 

tab, select Show Advanced Options and set the noted settings in the SMM as 
shown in Figure 15-11. 

Figure 15-11 Advanced Options Info Tab

10. Verify the firewalls and security programs are not causing a problem. Confirm that 
the PC does not have a firewall or a security program that will block the SMM’s 
access to the shared folder. This includes Windows firewall, and third party 
programs like McAfee and Norton.

Since the procedures for setting up shared folders vary from operating system to 
operating system, refer to your operating system manual for procedures on setting up 
shared folders.  

NOTE: An Apple™ Mac requires a new section in the SMB.CONF file to create a 
share. Add this section to the file. It can be located in /etc. You can use any text 
editor such as Vi or Pico. 
In this example the Music Folder lives in the Guest Account 
    [music] 
       path = /Users/Guest/Music 
       public = yes 
       guest ok = yes 
       only guest = no 
       writable = no 
       printable = no 
       browsable = yes
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Step 3: Setting Security (if applicable)
The SMM100 uses the PC guest account to access a share. If the guest account cannot 
be used,  a username and password must be provided.  The Security tab (Figure 15-12) 
allows you to set the username and password that the Streaming Music Manager will 
use to connect to computers with security enabled. The username and password you set 
for the Streaming Music Manager to use will need to be enabled on all computers that 
have security enabled that you want the Streaming Music Manager to search. If you are 
unsure if you need to set a username, skip this section.

Figure 15-12 Streaming Music Manager Security tab

NOTE: For security reasons, the Username and Password are not stored in the 
DigiLinX Dealer Setup software or project file. The Username and Password 
are stored in the Streaming Music Manager.

1. Connect the computer to the SwitchLinX. Security can only be set on a matched 
Streaming Music Manager.
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2. Click on the matched Streaming Music Manager.
3. In the right pane, click on the Security tab.
4. In the Username field enter the username required by the PC sharing the media.
5. In the Password field enter the password (remember the passwords are case 

sensitive).
6. Enter the password again in the Verify Password field.

Finally, click on the Send button. The Streaming Music Manager will now use this ID 
and password to access shared folders. 

NOTE: If you do not set up security, make sure that the guest account is enabled on the 
PC, with open authentication.

Step 5: Adding Cover Art
MP3 files can include cover art, but not all ripping software makes use of this feature. 
WAV files do not include cover art at all. The SMM100 will allow you to manually 
include cover art with music.  The PC must be part of the NetStreams workgroup to 
share music. 

To enable the SMM to find cover art, organize the music collection into artist/album 
directories. In each album directory, place a .jpg of the cover art.
1. Locate a .jpg image of the cover art for the album.

NOTE: Some music ripping software will include the album cover art in the directory 
with the music files.

Follow these steps to display album cover art:
2. Copy the file into the album folder associated with the art (see Figure 15-13 for an 

example).

Figure 15-13 Copying art to the album

3. Rename the file to “folder.jpg” (or to any cover art name you set in Cover Art in 
the Settings tab) (refer to Figure 15-12 and Figure 15-13). Your cover art should 
display on the TouchLinX. Repeat steps 1 through 3 for each album.

4. Select the Settings tab on the Streaming Music Manager.
Settings information displays (see Figure 15-13).
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Figure 15-14 Settings information tab

5. Edit the following (as needed):
Name - enter the name of the SMM100
Cover Art - edit cover art by:

adding - select Add to add keywords for the SMM100 to use in searching 
for cover art

removing - highlight the cover art keyword you want to remove and select 
Remove

editing - select an item to edit it.
Folder names - edit folder names by:

adding - select Add to add keywords for the SMM100 to use in searching 
for music folders

removing - highlight the folder name keyword you want to remove and 
select Remove

editing - select an item to edit it.
Select Apply.

Installation Review Checklist
On the PC:

Set the workgroup to Netstreams.
Enable the guest account.
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Set the music folder to “shared.”
Verify that there are no software firewalls blocking the SMM100 such as 
Windows firewall, and Norton or McAfee. 

On the Network:
Verify there are no hardware firewalls blocking SMM100.
Verify that the IP addressing scheme for the home network and DigiLinX are 
compatible.

On the SMM100:
Verify the services started.
Verify that all TCP/IP settings ae correct including:

IP address

Subnet mask

Gateway 

DNS

On DigiLinX:
The rest of the DigiLinX system works.
Streams are enabled.

Troubleshooting
Follow these steps to troubleshoot the SMM100:
1. Check to make sure that your streams are set up properly under the Streams tab of 

the SMM100.
2. Check to make sure that the following settings are correct and compatible:

IP address (make sure you are using the same addressing scheme across 
DigiLinX devices, the home network, and static devices)
DNS and gateway IP address for the home network mask is the same on all 
DigiLinX and home devices.
Subnet mask (make sure all subnet addresses are set to a Class C device 
255.255.255.0.

3. Browse to your C drive>Program Files>DigiLinX Dealer Setup>Tools>PC 
Client>Connect History.xml. Right click on ConnectHistory.xml and select 
Open with>WordPad. Edit the address as necessary to ensure the default host is 
set to the current address of your Streaming Music Manager as shown in Figure 15-
15.

Save the file after editing it.
Select the PC Client folder. Click on DigiFi. Desktop.UI. This will open the 
software.
Under Music libary, check to ensure that your music files can be seen by the 
Music Manager
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Figure 15-15 ConnectHistory.xml

4. Select the PCClient folder. Click on DigiFi.Desktop.UI. This will open the 
software.

5. Under Music Library, check to ensure that your music files can be seen by the 
Music Manager as shown in Figure 15-16.
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Figure 15-16 Music libary

Under Tools, check for system messages. Check to make sure your external 
devices can be seen.

6. Did you receive the following message? 
Could not authenticate 
If so, the guest account is not enabled or the SMM100 cannot access the PC.

7. To see if the SMM100 has received your configuration, type in the direct URL of 
the SMM100 into your web browser as follows (Device’s IP Address/
config_current.xml. (For example, http://10.15.1.254/config_current.xml).

Playlist Support
To have the Streaming Music Manager support playlists, put the M3U file in your 
Music folder so the Streaming Music Manager can find it.

Ripping Music
The following are examples of software that can be used to rip music from CDs to 
WAV or MP3:

Windows Media Player
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iTunes.

Any ripping software that will convert the songs into WAV or MP3 format should 
work.

NOTE: Digital Rights Management (DRM) protected music, such as music purchased 
from the iTunes™ music store, is not readable by the Streaming Music 
Manager.

Every tool has different options for naming the ripped tracks. Do not store the Artist 
name in the song title. The resulting filename is too long to be properly displayed on 
the TouchLinX. 

General Guidelines for Ripping Music
The following are a few general tips on ripping music:

Select the highest recording quality available.

Store music using the artist/album folder hierarchy (Figure 15-13 displays this 
hierarchy). 

Configure your ripping software to include only the Track name in the filename. 
This makes it easier to display the song title on the TouchLinX.

Windows Media Player Example
1. Open Windows Media Player.
2. Select Tools>Options.
3. Select the Rip Music tab.
4. Set the recording format to MP3. 
5. Select the File Name button. 
6. Ensure that only Track Name is selected in the options section.
7. Select OK twice to exit.

iTunes Example
1. Open iTunes.
2. Select Edit>Preferences.
3. Select the Advanced tab.
4. Ensure that “Import Using” is set to MP3 Encoder or WAV Encoder.

NOTE: If MP3 Encoder is selected, do not use the VBR (variable bit rate) option.
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5. Select the Importing tab. 
6. Uncheck the Create filenames with track numbers box. 
7. Select OK.

NOTE: Windows Media Player will automatically include cover art during the ripping 
process. The free version of MusicMatch and iTunes will not store cover art. 
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